engine error : failed to lock vertex buffer in CmeshDX8::LockVertexBuffer

Discussion in 'General Gaming' started by Charlie, Dec 8, 2004.

  1. Charlie

    Charlie Guest

    just bought Half-Life2 and tried to run it on my brandnew laptop computer (NEC PC-LR500AD, Pentium 1.4 MHz, ATI RADEON 9700).
    First got message that I have to update the video driver (checking on ATI's website, there seems to be an update... but I cannot install it.... & NEC tells me there is no update on their side).
    So, this was no solution yet.
    When Half LIfe2 is loading, when the word 'loading' appears... it blocks/freezes and gives me following error message '"engine error : failed to lock vertex buffer in CmeshDX8::LockVertexBuffer"'....

    Contacting Valve technical support... they bluntly tell me that it is because I have a DVD writer on my laptop... ?"#$%&' (meaning that HL2 could not be played on most of the new laptops available now????)... what a crap....

    Still looking for a solution! HL2 in the box only would not be nice ==> want to play it!

    Can anybody help me... as Valve seemingly cannot....
     
  2. pieface

    pieface Guest

    I hope someone can answer your question because I'm getting the exact same message
     
  3. MrCharlie007

    MrCharlie007 Guest

    I have a Dell Inspiron 8200 with DVD/CD-R player.

    I have the same problem. I will post the error messages I have come up against, just for fun. In addition to the "LockVertexBuffer" error, I also got (please note my video card is an ATI Radeon 9000) "Display Driver Stopped Responding: The ati2dvag display driver has stopped working normally." AND "Engine Error- hl2.exe-Application Error: The instruction at "0x241f94b7" referenced memory at "0x0106f5c0". The memory could not be "read".


    I have been to ATI's website and they do not support diver updates for Mobile/Laptop computers. They tell you on the website to go to the computer manufacturer and retrieve your update from there. The trouble is that the last update that Dell provideed was back in 2003.


    So if ATI, my computer manufacturer, and Steam cannot help, then can I return this useless software back to Steam or Valve of whoever will give me my cash back?

    What frustration! I should have downloaded the cracked version to see if I could even use this game.
     
  4. carlocosijns

    carlocosijns Guest

    STEAM is not helping me out either.... neither do ATI and NEC (notebook computer)....
    Have already HL2 for two months now... but it is getting really frustrating as I cannot play it.... and nobody can help??
     
  5. FireCrack

    FireCrack Newbie

    Joined:
    Jan 19, 2005
    Messages:
    710
    Likes Received:
    0
    Ah, i had this problem quite recently, the solution is simple...


    restart your computer.


    Well, atleast this worked for me, i got bothe errors mentioned in your last post.
     
  6. sj543210

    sj543210 Guest

  7. Ames

    Ames Newbie

    Joined:
    Sep 1, 2003
    Messages:
    5,621
    Likes Received:
    0
  8. Random Data

    Random Data Guest

    After spending a few hours trying to get rid of a similar error (LockVertexBuffer) after a reinstall of Windows, I worked out another factor - I'd enabled Terminal Services (Windows 2000). So if you're still getting this, or someone's Googling for solutions, try uninstalling Terminal Services or disabling Remote Desktop on XP.
     
  9. i had the same message as well...but now it works perfectly fine.

    first things first, i tried re-installing directx and botching that...so i ended up re-installing windows. after i had reinstalled windows, i tried with halflife 2 again. no joy.

    then i got an idea!

    i have two hard drives...andi had put halflife 2 on the slave drive, the one without windows (and therefore the drive without directx)...i re-installed halflife 2 to the master drive and viola! i was butchering headcrabs in no time.

    i am on a desktop though...dell dimensions with a radeon 9550...if that helps at all....i dont know much about your notebook problems.
    -tk
     
  10. Sigea

    Sigea Guest

    Whether residing on the master or slave drive makes a difference with hl2 I don't know, but DirectX availability to programs residing on either drive doesn't change; DirectX is part of the operating system.

    I was receiving the error mentioned in this topic's subject, and a suggestion by Shens provided me with a workaround. Adding " -dxlevel 70" to the launch options did it. The following is a link to my full post:

    http://www.halflife2.net/forums/showthread.php?p=1425632#post1425632
     
  11. beezle

    beezle Guest

    solution to CmeshDX8:LockVertexBuffer

    hey now,

    This appears to have worked for me, running a dual athlon MP system
    with an nvidia 6600GT. Are the rest of you having problems also running dual monitors like I am?

    If so - disable your second monitor in nview so that you are running a
    single monitor system. I was just able to play for an hour with no crash
    and no audio screwups either.


    ref: failed to lock vertex buffer CmeshDX8:LockCVertexBuffer

    hope this helps someone else
     
  12. laikiunreal

    laikiunreal Guest

    'Engine Error' ???

    :sniper: the error will occur when you Alt+Tab to switch between windows while playing a game and your machine is unable to allocate sufficient memory to render graphics when you switch back to your game window.

    The best solution for this behavior is to properly exit the game to return to your desktop so you may work with other applications.

    ATI Video Card Users
    This issue may also be related to an outdated driver for your video card. To address this issue, it is recommended that you uninstall the current Catalyst drivers, then install the Catalyst 6.2 drivers.

    Download the ATI Catalyst Uninstaller
    http://support.ati.com/ics/support/...t=050553d40196ef109fff37cbb40aaf28&deptID=894
    Install the ATI Catalyst 6.2 Drivers
    https://support.ati.com/ics/support/default.asp?deptID=894&task=knowledge&questionID=640
     
  13. mc6_aphex

    mc6_aphex Guest

    "Solution" ! ?

    Hello,
    I think i have the solution:(Well, that´s what worked for me ;-) )

    Try to change your "graphics aperture size". (this is an option in the "BIOS"... mosty fund under "Advanced Chipset Options" )


    My CS:S worked fine, until I changed my "GaS" from 128MB to 256MB. Then all this "vertex-trouble" began...
    I just changed it back to 128 Mb, and CS:S is running again ;-)

    I hope, i could help you..

    Aphex



    P.S: I am sorry for my bad english, I am not a native speaker :-P (to be presice, i am German). I just registered here, to tell you my solution, because I think, that ist the origin of all that trouble....
     
  14. S.T.A.R.S.

    S.T.A.R.S. Guest

    Well I tryed everything.I tryed to change my resolution,graphic effects,restart
    my laptop,delete file "vidcfg",I tryed it to delete with BAT file,I scaned my computer for viruses,spywares and adwares......and nothing.I even reinstall my whole windows.......it just doesn't work.
    NONE of that didn't work!!! :mad:
    I only made it on Half-Life 2....but on Counter-Strike Source,Half-Life 2 Death
    Match.....and other things from steam didn't work! :(:(:(:(:(:(
    But I noticed something......I already have this games longer then 1 year....
    and before it was working.....but after this new updates came in STEAM for
    counter-strike source,half-life 2 deathmatch ...and all other games in steam...
    that error started to coming all the time.Before this new updates for games in
    steam came...everything was working totally normal.But after this new updates
    came...that error "failed to lock vertex buffer in CMeshDX8::LockVertexBuffer"
    is just coming in the middle of the loading the game!!!
    Maybe that updates for games in steam are the reason why that error
    is coming and the games don't work!!! :(
    Anyway...like I said I made only the Half-Life 2 works.Just go in--->
    C:\Program Files\Valve\Steam\SteamApps\(then in your account)\half-life 2\
    bin\vidcfg.bin

    THATS IS!!! Now...delete that file "vidcfg.bin" then delete it from Recycle Bin
    then again go in that BIN folder,(where you deleted that file "vidcfg.bin"),and create an empty folder.Rename that folder in "vidcfg.bin"
    THATS IT!!!
    Now...turn of all that and try to turn on the Half-Life 2 game.It should work
    every time.

    AND PLEASE IF SOMEONE KNOWS HOW I CAN PLAY COUNTER STRIKE SOURCE
    AND HALF-LIFE 2 DEATHMATCH PLEASE TELL ME!!!


    Thanks in advance
     
  15. 99.vikram

    99.vikram Tank

    Joined:
    Apr 15, 2006
    Messages:
    4,324
    Likes Received:
    1
    The new updates shouldn't affect you this way.Are your drivers up to date? Did you load a new program recently?
     
  16. S.T.A.R.S.

    S.T.A.R.S. Guest

    Of course my drivers are up to date.But every time it says the my drivers are not up to date.Then I clicked on "Go to driver update page..."and it sent me directly on this site:
    https://support.ati.com/ics/support/default.asp?deptID=894&task=knowledge&folderID=27
    That is site on www.ati.com
    Of course.I downloaded the driver for ATI there.I downloaded FULL VERSION of it and I installed it.I done everything what steam wanted but it still says the my drivers are not up to date.And in the middle of the loading every time same error occurs:
    failed to lock vertex buffer in CMeshDX8::LockVertexBuffer
    And no.I didn't load any new program recently.Why do you ask?Counter-Strike Source and Half-Life 2 Deathmatch are working to you?
     
  17. Robinb

    Robinb Guest

    well, you can scratch Half Life 2: Episode 1 onto there... I ain't getting anywhere quickly...

    Getting exactly the same problems - HL2 requires a deleting of the file, whilst the Deathmatch just jumps ship... Hl2Ep1 makes no difference, oh, and this is the best part:

    My laptop is a Mobility Radeon 9700 made by Higrade. The game tells me to upgrade... yet ATI want nothing to do with it?!? and Hi-grade.. they still have the 6.14 drivers and are releasing nothing but... not very upto date...

    About to try the Omega drivers, see if they make a difference. But its wierd how Hl2: Lost coast with all its new graphics styles and rendering processes works like a charm (with the file deletion)... but Ep1 - no chance, and there basically the same...

    If this fails, anyone know the best way to get my money back? I ain't paying for sommit I can't play.

    Robinb

    quick addition:
    Done everything steam asks on there already pre-set answers.. and what others recommend (apart from omega drivers...) and this problem has been about now for.. what? 2.5 years? What are the changes of getting it fixed anytime soon, if they can't do it in 2.5 years!!
     
  18. Robinb

    Robinb Guest

    Ok, I can report that for my problem: Upgrading to the Omega Drivers latest version works like a charm - it does not have the security check that the ATI drivers have - and they appear to work of all (apart from laptops, where it must be later then the M6)

    Word of advice - don't upgrade this in a dark room at 2am - the upgrade did some crazy things until I did a full reset. but it does stop the HL2 errors.

    Robinb
     
  19. mastapenguin

    mastapenguin Newbie

    Joined:
    Mar 29, 2006
    Messages:
    114
    Likes Received:
    0
    All of you w/ dell laptops using ATI video cards, I have your solution.

    The ATI site doen't have the new drivers for you, but the Dell website does. Go to support options, enter the service tag for your laptop, and you should be able to find all the driver updates for the laptop hardware.

    Worked for me and my ATI X1400.
     
  20. S.T.A.R.S.

    S.T.A.R.S. Guest

    Give me a link of that site.:)
     
  21. Robinb

    Robinb Guest

    Indeed - dell requires the ATI specialist part - don't know why, and I have not tried the catalyst drivers, but there is special drivers.

    goto support.dell.co.uk (or com) and follow through to download drivers. Put in your service tag to get the correct ones - and remember - create a system restore and make sure you got backup drivers. Fixed too many computers that didn't do this. *sigh*

    Cheers,
    Robinb
     
  22. dimitrib

    dimitrib Guest

    same prob

    im having the same prob with the Cmesh dx80 thing , my computer works great on hl2 and css but when trying to play SinEpisodes the error comes out after like 5 minutes!!! I NEED HELP!!!
     
  23. S.T.A.R.S.

    S.T.A.R.S. Guest

    I made the Half-Life 2 and Half-Life 2 Episode One works good.But CSS and Half-Life Death Match are still not working.Can anyone help???????PLEASE!!!
     
  24. Titalion

    Titalion Guest

    oh god can any one provide a universal solution

    [​IMG]

    i have a nvidia geforce 7300 le G card the game works fine but at certain points the usual happens ^ not only in half life 2 but in episode 1 and even in mods like the half life 2 coop. i just need some one who has the game and has played it for a while and it worked fine for them then all of a sudden they got the engine error to replie a solution if they have one to me and anyone like me please...
     
  25. Shasta

    Shasta Newbie

    Joined:
    Dec 13, 2005
    Messages:
    1,073
    Likes Received:
    0
    Wow. This two page thread now spans THREE different years. How wonderful. Try the Steam support forums. And update your drivers and direct X first.
     
  26. zynalc

    zynalc Guest

    Hallo, i'm came from German and have a same Problem like you. My System with intel Core Duo Processor T2300 1.66G , Memory 1G and Nividia Geforce Go 7400. But anytime when i play my LIFE2, the message show up always. Ok. That's all. I'm looking a L?sung.
     
  27. zynalc

    zynalc Guest

    i don't agree. befor i buy HL2. I have tried a Demo on my laptop. From the very beginnen ist every thing just fine. until one day comes the update. than i have the same problem til now. Anyway i'll try the solution
     
  28. zynalc

    zynalc Guest

    hallo Titalion. i have the same situation. Befor i upgraded my steam ist everything perfect. Now ist really sucks. When i tried to quicksave the game or i pass throught some place which has many figures. The game get stuck and shows that message. what a pity. i mean it's a great game.
     
  29. stroopwafel

    stroopwafel Guest

    ive been bought HL2 to be able to play counterstrike:scourse.
    i have been playing it since last christmas, and it always ran fine...up until last week.. i started getting that same failed-to-lock-vertex-buffer crap...
    got an Nvidia7600 graph card...

    wut should i do to fix that shit so i can play normally again
     
  30. bennyy

    bennyy Guest

    stroopwafel,
    i get the same fkn problem i am so angry. i got Nvidia GeForce 7600 GT like you. its like WTF??? i bought this game and now im not being able to play oh man i am so pissed off.....
     
  31. hi, im getting exactly the same message, and i tried removing the video (.bin thingy) file, and other stuff, etc.

    pain in the bum...
     
  32. MorganFreeman911

    Joined:
    Jan 27, 2006
    Messages:
    3,719
    Likes Received:
    2
    Oh wow, nice bump.
     
  33. El Diablo

    El Diablo Guest

    NVIDIA GeForce 6200 LE
    my error seems differnt though... it says the same thing but ill go into CS:S and play for about 30 secounds and then my game freezes, crashes and then the error pops up... im not ALT+Tab switching on windows like the Steam support page said... so idk
     
  34. acjordan

    acjordan Guest

    I get the same message it's really random up until the point I'm at now. I was just restarting the computer and trying again and it was working now I'm at the loading section with the second tunnel with the car. :( I was able to get through Portal but even then this error poped up a couple times.
     
  35. soulslicer

    soulslicer Tank

    Joined:
    Mar 16, 2007
    Messages:
    4,624
    Likes Received:
    4
    wow..shasta..

    the memories
     
  36. eyekillu

    eyekillu Guest

    cmeshdx8::lockvertexbuffer info

    nvidia 7100 gs 256mb, amd 2x athelon, and 1gig ram. i have a few specifics on my cmeshdx8 crash. i can play gun game maps almost all day long. i might get a cmesh crash 1 out of 40 gun games. but it always crashes if i play any cs_office maps, or anything of the like. i can play for about a min or two before the crash, but always crashes under those maps.

    my drivers are up to date and installed properly. i had this problem a lot a few months ago, then magicly it dissapeared. i thought it was my new drivers. but without updating, the problem came back...right after a steam update. so i updated my drivers and still have the same problem.

    judging from some personal research, this may be a ram issue. according to a post on another forum, your video might crash if the info cant be loaded from the ram fast enough. this might be inacurate, but anything that helps at this point is probably welcome i imagine.

    also, i have a lot of custome skins and models installed. i think this may have exacerbated the problem. the extra loading required might have somthing to do with this.

    well, ive been reading posts like this for months now and havnt seen any this detailed, so i thought i would throw in my two cents. sorry so long, just trying to be helpful.
     
  37. sH0wB0aT

    sH0wB0aT Guest

    I have the same problem. Use 2 1GB modules which add up to 2GB. When I remove one, for some reason I get less to no crashes at all. When I load both of them together, the crashes begin again.
     
  38. Tyguy

    Tyguy Space Core

    Joined:
    Aug 22, 2004
    Messages:
    7,991
    Likes Received:
    6
    gotta be a driver problem, i installed a more recent driver and it started....
     
  39. sH0wB0aT

    sH0wB0aT Guest

    I've rolled back to previous drivers and I still have the same problem. Even tried beta drivers, modified drivers, etc.

    BTW, I have the same video card as you.

    8800GTS 640MB.

    Did you try out the NGO modified drivers by any chance?
     
  40. eyekillu

    eyekillu Guest

    what speed is your ram? maybe the problem lies in that, or even in system board drivers. im hesitent to update my system board drivers. i dont want to create a new problem...you know, if its not broken dont fix it. but as of now im using generic motherboard drivers, and its an nvidia motherboard. so maybe try ram that was produced for gaming or try new board drivers.

    just a few more theories.
     

Share This Page