LCD woes

Discussion in 'Counter-Strike' started by skose, Aug 23, 2007.

  1. skose

    skose Guest

    Hello all,

    I finally got rid of the ole CRT monitor. It's been replaced with a 16:10 20.1" LG LCD monitor. The monitor boasts a 2ms response time, but unfortunately it's maximum refresh rate is 60Hz at the native resolution.

    When I play source, I'm perfectly satisfied with the framerates I get and the overall look of the game. However, I'm getting periodic 'lag' or frame rate drops. It doesn't seem to be at all related to my hardware, because I can be standing still looking at a wall or general scenery and the drops will still occur consistently. (When I say periodic, I mean just that :p). I tried busting the resolution down (even though it looked shitty) just to see if a boost in refresh rate would help the problem. No luck. I also turned all my graphics / textures / shader / gfx effects to minimize card usage. No luck. I'm awaiting a DVI cable from newegg right now. Perhaps going digital input will help. As it is now, I'm running a VGA cable to a converter to plug into my nvidia 7600GTs dvi port (no vga slot on it)

    Anyone have any ideas how I can troubleshoot this / what might be wrong? The only other game I've tried on my new monitor is the Bioshock demo. Although I have to turn settings to medium and run at a non-native resolution, I don't get any periodic bumps in my rate. I need consistency!

    Thanks
     
  2. Asus

    Asus Newbie

    Joined:
    Aug 22, 2003
    Messages:
    10,350
    Likes Received:
    0
    LCD refresh rate doesn't have the same effect as CRTs. Response time is what will determine how fast the image updates on the LCD.

    Just make sure Vsync is disabled. If it's on and your PC from time to time can't maintain 60FPS then it drops to 30FPS to keep sync. Nothing in between.
    And you might try a different connection on the video card too. I assume there is 2. I guess you have to wait for the DVI cable.
     
  3. skose

    skose Guest

    thanks

    My goodness Asus. You're a friend to a man in need indeed indeed. In my nVidia control panel, I had to go to application specific settings to turn off vertical sync for cs:s. Maybe 'wait for vertical sync' is the most confusing cvar of all? My understanding originally was that 'disabled' would mean vsync would be off. Perhaps it means, 'wait for windows specific settings' ? so being disabled would mean it overrides to turn it on anyway? I have no clue. But the problem is fixed and I can now enjoy beaaaaautiful gameplay with my new 20.1" monitor....oh yeah!

    Thanks
     

Share This Page