ERROR:delete of Steam.exe failed, Win32 Error 5 "Access Denied"

Discussion in 'General Gaming' started by Road_Trauma, Nov 19, 2004.

  1. Road_Trauma Guest

    Member Since:
    Message Count:
    0
    Trophy Points:
    0
    I have installed both HL2 & CS:S drom 5 CD retail and when steam trys to update i get to 27% and it just stops and i get this;

    Steam.exe (main exception): ERROR:delete of Steam.exe failed, Win32 Error 5 "Access is Denied"

    Any 1 able to help me with this?

    :sniper: Steam :angry:
  2. we11er Newbie

    Member Since:
    Jan 13, 2004
    Message Count:
    1,036
    Trophy Points:
    0
    Location:
    UK
    Someone else had this same problem just a few hours ago, I'll try and find the thread.

    edit: actually, you might be the same guy if it was steampowered forums?
  3. bikerdave Guest

    Member Since:
    Message Count:
    0
    Trophy Points:
    0
    Im a lady and it sounds like you have a right old bugger of a problem.

    I would format c: and start from scratch, much quicker than ironing out a problem that is quite rare....
  4. Bluechair Newbie

    Member Since:
    Sep 17, 2003
    Message Count:
    98
    Trophy Points:
    0
    ^^^^

    If you know what you are doing this is a good solution...If not keep looking...
  5. Member Since:
    Message Count:
    0
    Trophy Points:
    0
    I've got the same Win32 Error5 problem

    Hi:

    I have the same problem.

    There is a page on Steam's tech support site giving a partial answer, but it didn't help me.

    The mains thrust of their advice is that another program is interfering with the Steam installation. The writer describes a very odd function to the Steam installation, in that it first installs an earlier version of steam which it then begins to uninstall and overwrite with the current version. It is at this 27% point of the installation that the "hand-off" to the new installation is interefered with by "something". They mention two programs by name, Cybersitter, and Windowsblinds, (neither have ever been on my machine) which should be removed or disabled prior to attempting the installation of Steam.
    They also go on to mention either a firewall or anti-virus program (mostly a firewall not allowing the modified program to run - a trojan or virus like behaviour). So Steam's next route is to blame some form of system corruption or infection.
    Unfortunately, in my case there is no evidence (that my skill level can locate) of any of these issues. I ran full virus scans and used both Adaware and Spybot - Search and Destroy, to ensure my system was clean. If there is something wrong, it's something these tools can't find.
    I then tried to install from a Clean boot (through msconfig, no antivirus or firewall running) - just the minimum necessary to run Windows - nothing else. Tried two attempts (uninstalling the partially installed Steam and cleaning the registry with Regcleaner) Same result.

    If you have any luck - please let me know.....
  6. we11er Newbie

    Member Since:
    Jan 13, 2004
    Message Count:
    1,036
    Trophy Points:
    0
    Location:
    UK
    Sounds a bit dodgy to me - poor effort valve...

    What I'd suggest is closing as many processes as you can. Press Ctrl + Shift + Escape to bring up the task manager and close down unnecessary programs. Be careful not to close anything critical.

    This should minimize interference with the setup program.
  7. Member Since:
    Message Count:
    0
    Trophy Points:
    0
    Hi to everybody:

    After relentlessly digging through the forums, I found this post by someone with a great more experience and skill than I. It worked for me, give it a try. I have pasted his procedure below. Good Luck!

    What I Did...
    Maybe this isn't an "approved" method, but it allowed me to get into the game after about 2 hours of troubleshooting:

    1. Remove any old versions of Steam.
    2. Download the Steam client.
    3. Download PrcView - a freeware utility that displays running processes. http://www.xmlsp.com/pview/prcview.htm
    4. Run PrcView.exe. You'll see a list of running processes. Keep this somewhere visible, so you can monitor it and click on it.
    5. Run the Steam.exe
    6. You'll see Steam.exe listed in Process Viewer as a running process.
    7. Watch it closely.
    8. Soon, you'll see SteamTmp.exe launch. When you see this launch, immediately Kill the Steam.exe manually.
    9. The SteamTmp.exe will close, and then continue running again as Steam.exe (a new Steam.exe not the one you killed in Step 8 above).
    10. Continue updating as normal, and close Process Viewer.
    11. Everything should be good to go!

    While the above is necessarily perfect, it will circumvent any other SP2, Winblind, A/V, or other apps that could be causing problems with closing of processes in a timely manner.

    When I monitored the processes using PrcView.exe, I did notice that eventually, the original Steam.exe would close. Unfortunately, SteamTmp.exe would "time-out" waiting for this to happen.

    IMHO, if they simply increased the "time-out" as it waits for the old Steam.exe to close, a majority of users issues would be resolved.... Or, they could simply issue a forced "Kill" of the process themselves...

    Not clean, but it works!

    Me again: Unfortunately, now after my success installing Steam, I went out and bought the retail box copy.

    Now I can't install the game due to either "Error 1335" and corrupted "hl22.cab" files or "Error 1334" and "hl23.cab" files.

    What a nightmare....

    The worst part is that unless a miracle arrives, I will be returning this to the retailer - and it isn't his fault.

    Valve has done so much to protect themselves from piracy, that they have created a product with a huge usage failure rate. We only have to read others posts to know that comment is in perspective.

    You only have to read the limited attempts at solving problems on their tech support site to understand the utter disdain they show for their customers....
  8. Road_Trauma Guest

    Member Since:
    Message Count:
    0
    Trophy Points:
    0
    Thanx All_Steamed_Out

    This worked but I only followed steps 5-8, did not need PrcView just used the normal 1 with alt+crtl+del, saw steam then steamtmp and killed the other 1 and all went well.

    But my dad the tool took my copy of HL2 and installed it on his PC and now i cant use MY CD key!!!!! But hes gunna buy me another copy tommorow so its ok.

    Thanx again m8
  9. Member Since:
    Message Count:
    0
    Trophy Points:
    0
    You can never trust family....

    After installing Steam I had a lot of trouble installing Half-Life2 itself. More error messages suggesting the CD's had corrupted files. Turned out it didn't like my DVD reader and preferred to load from my CD-RW drive instead. Watch out for that issue when you get your new copy
  10. kelloggfan Guest

    Member Since:
    Message Count:
    0
    Trophy Points:
    0
    Easy Fix!!!! Easy Fix!!

    first off...if you're telling someone to format the drive instead of finding an easy fix, I would say, "don't quit your day job", unless of course if you work in IT. That job is not for you!!

    FIX:

    Reboot your computer into "safe mode with networking". Run steam.exe while in safe mode. This will update and complete. Steam will then start and run. Reboot your computer into normal mode. Run steam...it should run normally.

    I am running WinXP pro sp2. :bounce::bounce:
  11. MpakoLaki Guest

    Member Since:
    Message Count:
    0
    Trophy Points:
    0
    no safe modes :S not working

    at least for me

    i went on safe mode o uninstall everething
    and the again on 26% it stop and
    steam.exe (main exception):RROR: delete of steam.exe failed, win32 Error 32 "The process cannot access the file because it is being used by another process."


    and here is the solution you asking for
    i bet you all have (except this problem :>) the spybot S&D well try to close the TeaTimer and you will find out that all running normall :>

    dont format
    dont delete nothing
    dont replace any folder

    cheers :>
  12. Bahooga Guest

    Member Since:
    Message Count:
    0
    Trophy Points:
    0
    Solution

    Hello people,

    I found a conflicting program with the steam install. The program is call SuperDU Controller. It is a program that can limit up and downloadspeeds. It runs in the background and has an icon in the systemtray. Just close the apllication and run the setup. Steam will now properly update. After you reboot, or start the SuperDU Controller manually, both programs should work fine. There are also similar programs to SuperDU Controller available, so they might be causing an update problem, but that is speculation.

    Anyway, thought you people would like to see another possible solution to your problem.
  13. spike09 Guest

    Member Since:
    Message Count:
    0
    Trophy Points:
    0
    Top poster just joined to say thanks fixed my updating problem TYVM :smoking:
  14. Pete Newbie

    Member Since:
    Mar 8, 2009
    Message Count:
    4
    Trophy Points:
    0
    Correct me if i am wrong but i found the solution to this to be pretty obvious.

    It can't delete steam.exe if you are installing from a CD/DVD as it will be write protected.

    All i did to fix this problem was copy steam.exe, SteamInstall_English.msi and setup_english.ini to my desktop and then ran it from there after making sure they were not write protected by right clicking them and selecting properties, worked a treat with no problems.

    In my case i was installing saints row 2. It might be different for other games.

    But i hope that helps.
  15. Member Since:
    Jan 27, 2006
    Message Count:
    3,749
    Trophy Points:
    52
    Location:
    Surrey ,BC
    Whoah, this thread was really bumped.
  16. Pete Newbie

    Member Since:
    Mar 8, 2009
    Message Count:
    4
    Trophy Points:
    0
    Yeah true, lol. Never come across this problem before.

    But maybe it will still come in useful to someone :E
  17. midimaxum Newbie

    Member Since:
    Jul 20, 2009
    Message Count:
    1
    Trophy Points:
    0
    Fix for Windows 7 Users?

    I've been getting this error message upon installing Steam for the first time on Windows 7 64-bit.

    What I ended up doing was...

    Go to ...Program Files/Steam/
    Right click on Steam.exe and go to the Properties...
    Click on the Compatibility tab...
    Check Run as Administrator and hit okay...
    Then I deleted StemeTemp (or something like that. has the steam icon)...
    Then run Steme.exe again.
    It will display a windows suggested not to run Steam in compatibility mode, just hit Cancel to override it.
    And ta DA!

    It worked for me, dunno if this could help others.

    Note: I haven't installed and played any games yet, so I'm not quite sure if the error will pop up again when starting a one.
  18. snydez2009 Newbie

    Member Since:
    Sep 3, 2009
    Message Count:
    1
    Trophy Points:
    0
    I also had this problem. I'm running Windows 7 ultimate 7600 64-bit.

    This is how I solved the problem.

    Open the start menu...
    Right click on My Computer and select "Manage"...
    Select "Local Users and Groups"...
    Select "Users"...
    Right click "Administrator" and uncheck "Account is disabled"...
    Hit apply and log off...
    Log into "Administrator"...
    If Steam is uninstalled then install Steam and it should work correctly...
    If Steam is already installed then just run it and it should update completely.

    This fixed my problem, I hope it fixes yours too!
  19. R3n3gade66 Newbie

    Member Since:
    Sep 5, 2009
    Message Count:
    1
    Trophy Points:
    0
    I think I found the easiest solution for this problem. Instead of launching via the Steam link, launch via the HL2 link or Tf2 link. I did this, and it managed to get past the 27% mark and continue updating. It then launched the game I wanted to play. As for Steam itself, it works.

    If I'm wrong, ok. If I'm right, it'll save a lot of uninstalling, rebooting, safe-moding, etc. :)

    I'm also using W7 64-bit, BTW.
  20. el1jahxtm Newbie

    Member Since:
    Apr 10, 2010
    Message Count:
    1
    Trophy Points:
    0
    HA! ive found a permanent fix for win 32 error 5.
    i had the same problem. so navigate to your steam folder in program files and look for 2 folders, bin, and some other one. one of those folders has 1 application, steam... click and install.
    DONE
    there ya go
  21. jaxx0rr Newbie

    Member Since:
    Jul 16, 2010
    Message Count:
    1
    Trophy Points:
    0
    dont continue to use steam installer..
    after you get the error just go to steam folder and start steam.exe.. it should now close ok and start updating..
  22. Hassou Tobi Newbie

    Member Since:
    Oct 12, 2010
    Message Count:
    1
    Trophy Points:
    0
    i get this problem..... "0x241f8977 referenced memory at 0x00daf5c0. could not be read".... what is this? hhow do i fix this?? so pissed at it :angry:
  23. Gavin Newbie

    Member Since:
    Nov 11, 2010
    Message Count:
    1
    Trophy Points:
    0
    Thanks very much, had this problem installing black ops. Found your post through google. Just wanted to say thanks. And the registration page on this forum is 'orrible
    :smoking:
  24. reigh Newbie

    Member Since:
    Apr 20, 2011
    Message Count:
    3
    Trophy Points:
    0
    Well I am a Vampire and... I would like to suck yoru blood for that "genius"???
  25. reigh Newbie

    Member Since:
    Apr 20, 2011
    Message Count:
    3
    Trophy Points:
    0
    How are you killing the process quick enough once the temp steam exe shows in my task manager it is only seconds before timeout not long enough to click and verify end process not to mention I am denied at that.
  26. reigh Newbie

    Member Since:
    Apr 20, 2011
    Message Count:
    3
    Trophy Points:
    0
    This turned otu to be the issue I temporarily turned off Kaspersky internet Security my anti-virus and then steam worked perfectly.
  27. Inanimate Spy

    Member Since:
    Sep 4, 2004
    Message Count:
    210
    Trophy Points:
    32
    Location:
    Stockholm - Sweden
    Question

    Steam fails to install or update and returns the error Steam.exe (Main Exception): ERROR: delete of steam.exe failed,Win32 Error 5 'Access is denied' or Steam.exe (main exception): ERROR: deleted Steam.exe but the file is still there - what should I do?
    Steam attempts to update but repeatedly progresses to 26 or 27% then restarts the update, or stalls at 27%.

    Answer

    This error is caused by a lack of user permissions, having the Steam.exe file attributes set to "Read Only", or by another program interfering with Steam's installation process (if the Steam client application has been updated to a version which was not included with your Steam installer package, Steam will download a new copy of itself and then delete the old Steam.exe file unless another program interferes).
    Check your Windows user permissions
    Please ensure that you are logged in as an administrator on the machine which you are using to install Steam.
    Check file attributes
    Right-click on the Steam.exe file which was created after running the Steam Installer and select Properties
    Uncheck the Read-only checkbox if it is checked and hit Apply before closing the window
    Try running the Steam.exe file once more

    Check your security software's settings
    If you are running an antivirus program, firewall program, or any security product which may be interfering with the deletion and replacement of the Steam.exe file (some security software will check a file's information every time it is changed and block automatic replacement of files) please check your settings for the program and make sure that you are prompted to allow activities which may trigger the security software.

    Disable any programs which interfere with Steam

    Remove Spyware, Adware, and Viruses
    If the issue persists it is possible that a virus, adware, or spyware may be interfering with the installation process. Please see the topic linked below for instructions to remove the offending program:

    ------------------


    Software that interfere with Steam

    The following applications have been known to cause issues with Steam and playing games:
    Anti-Virus Applications - Any Anti-Virus program could potentially block Steam and Steam game access, especially when not properly configured for use with Steam. Please make sure that Steam and all Steam games are listed as exceptions in these programs. If the issue persists, please try disabling or temporarily uninstalling the program to test the issue.
    Avast!
    AVG Anti-virus *
    F-Secure
    Iobit Advanced System Care *
    Kaspersky Anti-virus
    McAfee Anti-virus
    Nod32 Anti-virus *
    Norton/Symantec Anti-virus
    Panda Anti-virus
    Threatfire
    Trend Micro
    VIGuard Anti-virus
    Anti-Spyware Applications
    Ad Aware
    CA Pest Patrol
    PC Tools Spyware Doctor with AntiVirus (may need to disable Full-Screen detection in the Advanced settings)
    Spybot Search & Destroy
    Spycatcher Express
    Spyware Terminator
    Webroot Spy Sweeper *
    Firewall/Security Applications
    CA Internet Security Suite
    Comodo (With Portal 2 running the firewall in Defense+ in training mode allows the game to run)
    CYBERsitter
    ESET Smart Security
    Netlimiter
    McAfee Personal Firewall
    Nvidia Network Access Manager/Firewall *
    Nvidia ForceWare Intelligent Application Manager
    Outpost Firewall (Disabling System Guard under Proactive Protection allows Portal 2 to run)
    Panda Internet Security
    Peer Guardian
    PeerBlock
    Tiny Personal Firewall
    Verizon Internet Security Suite
    Zone Alarm
    Other Applications
    IOBit Advance System Care
    Airfoil

    Alcohol 120%
    AOLacsd.exe (AOL connection driver)
    ATI Hotkey Poller
    BitTorrent/uTorrent (all clients)
    Creative Software (Alchemy, MediaSource 5 on Asus G60VX models specifcally)
    Catalyst AI
    Daemon Tools
    Download Accelerators (all clients)
    EVGA Precision
    Garfield Daily Desktop Comic
    GhostSurf 2007
    Google Toolbar, Google Updater
    GSC
    Hamachi
    K-Lite Codec Pack
    LimeWire, BearShare or other Peer 2 Peer applications
    LogMeIn
    Microsoft Screen Magnifier in Windows 7 (magnify.exe - may cause in-game cursor issues)
    MSI Afterburner
    nProtect GameGuard *
    PC Time Limit
    Skype
    Slysoft AnyDVD
    StarDock KeepSafe
    SteamWatch
    iolo System Mechanic
    TeamSpeak (can lead to mic issues)
    Total Recorder
    Tuneup WinStyler Theme Service
    UPEK Protector Suite
    Ventrilo (can lead to mic issues)
    VirtuaGirl 2
    Western Digital Backup Anywhere
    Whitesmoke Translator (may cause the Source engine to crash)
    WindowBlinds
    Xfire

    * We recommend that applications listed in bold with a ( * ) symbol are fully uninstalled from your system if disabling them does not resolve the issue
  28. darkomen8 Newbie

    Member Since:
    Aug 22, 2011
    Message Count:
    1
    Trophy Points:
    0
    I just encountered this problem tonight, after searching the forums and not finding anything useful i tried simply making sure write protection was disabled for the steam folder.
    This solved my problem in seconds...
  29. Acepilotf14 The Freeman

    Member Since:
    Aug 29, 2006
    Message Count:
    13,179
    Trophy Points:
    124
    Location:
    Califerniah
    You are all years late, friends.