ATI drivers, wtf @ you

Discussion in 'Hardware & Software' started by _Z_Ryuken, Sep 16, 2007.

  1. _Z_Ryuken

    _Z_Ryuken Newbie

    Joined:
    Dec 22, 2005
    Messages:
    3,835
    Likes Received:
    0
    So I have 7.14 installed, and CS:S gives me a message saying it's not up to date. The first time I got this message I got the 7.5 drivers which were new at the time.
    I installed them, or thought I did. Still coming up as 7.14.
    7.8 was released and I got that, installed it, or thought I did, but no, same CS:S error. The game plays fine so I never tried to correct it until now.

    I downloaded the Quake Wars demo via Steam and got an error. See attachment.

    I uninstall my video driver, and once again click the 7.8 installer and the box is checked to install the driver.

    I install the driver and lo and behold, it's still 7.14. :|

    WTF?
     

    Attached Files:

  2. _Z_Ryuken

    _Z_Ryuken Newbie

    Joined:
    Dec 22, 2005
    Messages:
    3,835
    Likes Received:
    0
    Here's a summary of the driver specs and whatnot.
     

    Attached Files:

  3. PimpinPenguin

    Joined:
    Mar 10, 2006
    Messages:
    2,547
    Likes Received:
    1
    Just ignore Steam that's what i do as long as it workin fine why bother.
     
  4. _Z_Ryuken

    _Z_Ryuken Newbie

    Joined:
    Dec 22, 2005
    Messages:
    3,835
    Likes Received:
    0
    I bother because I don't even know if my drivers are up to date. Is ATI's latest driver still 7.14 or is it 7.8?

    I want to play the Quake Wars demo and it won't let me because of my "gfx card/ driver combination", and unless I know I have the latest drivers I won't know how to start fixing that problem.

    If anyone else with an ATI card could just reply, it would be really easy to tell me what version you have, and if you have an X1900GT, whether you can play Quake Wars.
     
  5. Asus

    Asus Newbie

    Joined:
    Aug 22, 2003
    Messages:
    10,350
    Likes Received:
    0
    Notice it says Cat driver version 7.8 (2nd line). Ignore the Direct3D version inside the driver. People don't quote that when telling you which driver to update to.

    I also rarely update unless there is an issue. If you update with each new release then you might update into issues...not good.
     

Share This Page